]> Pileus Git - ~andy/sunrise/blob - games-strategy/opendungeons/opendungeons-9999.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / games-strategy / opendungeons / opendungeons-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit cmake-utils eutils git-2 games
8
9 MY_PN=OpenDungeons
10
11 DESCRIPTION="An open source, real time strategy game based on the Dungeon Keeper series"
12 HOMEPAGE="http://opendungeons.sourceforge.net"
13 EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}"
14 EGIT_BRANCH="development"
15
16 LICENSE="GPL-3 CC-BY-SA-3.0"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE=""
20
21 RDEPEND=">=dev-games/cegui-0.7.0[ogre,opengl]
22         >=dev-games/ogre-1.7.0[cg,freeimage,ois,opengl]
23         dev-games/ois
24         dev-libs/libpcre
25         dev-libs/zziplib
26         games-strategy/opendungeons-data
27         media-libs/flac
28         media-libs/freeimage
29         media-libs/freetype:2
30         media-libs/libogg
31         media-libs/libsfml
32         media-libs/libsndfile
33         media-libs/libvorbis
34         media-libs/openal
35         virtual/opengl"
36 DEPEND="${RDEPEND}
37         virtual/pkgconfig"
38
39 CMAKE_IN_SOURCE_BUILD=1
40
41 src_configure() {
42         local mycmakeargs=(
43                 -DOPENDUNGEONS_DATA_PATH="${GAMES_DATADIR}"/${MY_PN}
44                 -DOPENDUNGEONS_BINARY_PATH="${GAMES_BINDIR}"/${MY_PN}.bin
45                 -DBINDIR="${GAMES_BINDIR}"
46                 )
47
48         cmake-utils_src_configure
49 }
50
51 src_install() {
52         cmake-utils_src_install
53         doicon "${FILESDIR}"/${PN}.svg || die
54         make_desktop_entry ${MY_PN} ${PN} ${PN}
55
56         prepgamesdirs
57 }