]> Pileus Git - ~andy/sunrise/blob - games-rpg/touche-demo/touche-demo-1.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / games-rpg / touche-demo / touche-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Touche: The Adventures of the Fifth Musketeer (interactive demo)"
8 HOMEPAGE="http://wiki.scummvm.org/index.php/Touch%C3%A9:_The_Adventures_of_the_Fifth_Musketeer"
9 SRC_URI="http://gentooexperimental.org/~unlord/touche_demo.zip"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.10.0"
18 DEPEND="app-arch/unzip"
19
20 S=${WORKDIR}
21
22 src_install() {
23         local dir=${GAMES_DATADIR}/${PN}
24         insinto "${dir}"
25         doins DATABASE/TOUCHE.DAT \
26                 OBJ \
27                 V100 \
28                 V101 \
29                 V103 \
30                 V26 \
31                 V91 \
32                 V93 \
33                 V97 \
34                 V98 || die "doins failed"
35
36         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" touche"
37         make_desktop_entry ${PN} "Touche: The Adventures of the Fifth Musketeer (Demo)"
38
39         prepgamesdirs
40 }