]> Pileus Git - ~andy/sunrise/blob - games-rpg/simon2-demo/simon2-demo-1.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / games-rpg / simon2-demo / simon2-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="Simon the Sorcerer 2 (interactive demo)"
8 HOMEPAGE="http://www.adventuresoft.com/gs2.html"
9 SRC_URI="http://quick.mixnmojo.com/demos/simon2demo.zip
10         http://gentooexperimental.org/~unlord/simon2demo.zip"
11
12 LICENSE="freedist"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 RESTRICT="strip"
17
18 RDEPEND=">=games-engines/scummvm-0.8.2"
19 DEPEND="app-arch/unzip"
20
21 S=${WORKDIR}/simon2demo
22 dir=${GAMES_DATADIR}/${PN}
23
24 src_install() {
25         insinto "${dir}"
26         doins gsptr30 icon.dat simon2.gme simon2.voc stripped.txt tbllist || die "doins failed"
27
28         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" simon2"
29         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
30         make_desktop_entry ${PN} "Simon the Sorcerer 2 (Demo)" ${PN}.png
31
32         prepgamesdirs
33 }