]> Pileus Git - ~andy/sunrise/blob - games-rpg/samnmax-demo/samnmax-demo-1.ebuild
app-arch/paq8l: Adding ~amd64 keyword
[~andy/sunrise] / games-rpg / samnmax-demo / samnmax-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Sam & Max Hit the Road (interactive demo)"
8 HOMEPAGE="http://www.samandmax.net/?section=hittheroad"
9 SRC_URI="http://gentooexperimental.org/~unlord/${PN}.rar"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="|| (
19         app-arch/unrar
20         app-arch/rar )"
21
22 S=${WORKDIR}
23 dir=${GAMES_DATADIR}/${PN}
24
25 src_install() {
26         insinto "${dir}"
27         doins SNMDEMO.{SM0,SM1} MONSTER.SOU || die "doins failed"
28
29         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" samnmax"
30         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
31         make_desktop_entry ${PN} "Sam & Max Hit the Road (Demo)" ${PN}.png
32
33         prepgamesdirs
34 }