]> Pileus Git - ~andy/sunrise/blob - games-rpg/pylotro/pylotro-0.1.14.ebuild
games-rpg/dwarf-fortress: generic name for wrapper script
[~andy/sunrise] / games-rpg / pylotro / pylotro-0.1.14.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2:2.5"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.4 3.*"
10
11 inherit games distutils
12
13 DESCRIPTION="Lord of the Rings Online and Dungeons & Dragons Online Launcher"
14 HOMEPAGE="http://www.lotrolinux.com/"
15 SRC_URI="http://www.lotrolinux.com/PyLotRO-${PV}.tar.bz2"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 DEPEND="dev-python/PyQt4
23         dev-python/4suite"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}"
27
28 PYTHON_MODNAME=PyLotROLauncher
29 PYTHON_VERSIONED_SCRIPTS="${GAMES_BINDIR}/${PN}"
30
31 src_install() {
32         distutils_src_install \
33                 --install-scripts "${GAMES_BINDIR}" \
34                 --install-data "${GAMES_DATADIR}"
35         prepgamesdirs
36 }
37
38 pkg_postinst() {
39         distutils_pkg_postinst
40         games_pkg_postinst
41
42         elog
43         elog "You will need a proper wine or crossover-game installation to launch"
44         elog "the game. You can find more information on how to run these games in"
45         elog "GNU/Linux by visiting:"
46         elog "http://appdb.winehq.org/objectManager.php?sClass=application&iId=4891"
47         elog "or http://www.codeweavers.com/compatibility/browse/name/?app_id=4029"
48 }