]> Pileus Git - ~andy/sunrise/blob - games-rpg/privateergold/privateergold-1.03.ebuild
www-misc/abloadtool: Fix qt deps
[~andy/sunrise] / games-rpg / privateergold / privateergold-1.03.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit eutils games
8
9 DESCRIPTION="WC: Privateer Gemini Gold, remake of the adventure space flight simulation"
10 HOMEPAGE="http://privateer.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/privateer/PrivateerGold${PV}.bz2.bin"
12
13 LICENSE="GPL-2 PGG-AL"
14 SLOT="0"
15 KEYWORDS="-* ~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
19                 app-emulation/emul-linux-x86-gtklibs
20                 app-emulation/emul-linux-x86-opengl
21                 app-emulation/emul-linux-x86-xlibs )
22         x86? ( virtual/opengl
23                 x11-libs/gtk+:1
24                 x11-libs/libICE
25                 x11-libs/libSM
26                 x11-libs/libX11
27                 x11-libs/libXext
28                 x11-libs/libXi
29                 x11-libs/libXrandr )"
30
31 S=${WORKDIR}
32
33 src_unpack() {
34         unpack_makeself
35 }
36
37 src_install() {
38         dodoc Manual.pdf || die "Installation of docs failed"
39         newgamesbin "${FILESDIR}"/privscript privateergold || die "Couldn't install launcher"
40         insinto "${GAMES_DATADIR}/${PN}"
41         doins -r * || die "Installation of game data failed"
42         make_desktop_entry ${PN} "Privateer Gemini Gold"
43         prepgamesdirs
44         fperms ug+x "${GAMES_DATADIR}/${PN}"/bin/{privgold,privserver,privsetup,soundserver,vsinstall.sh} || "chmod of game bins failed"
45 }
46
47 pkg_postinst() {
48         elog "You can change game options with ${GAMES_DATADIR}/${PN}/bin/privsetup"
49         elog "There is a manual and an intro under ${GAMES_DATADIR}/${PN}/"
50         ewarn "Having /tmp mounted with noexec will cause the game to segfault"
51         ewarn "at startup under kernel 2.6.39"
52 }