]> Pileus Git - ~andy/sunrise/blob - games-rpg/planeshift-bin/planeshift-bin-0.4.03.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / games-rpg / planeshift-bin / planeshift-bin-0.4.03.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="A 3D Fantasy MMORPG"
8 HOMEPAGE="http://planeshift.it"
9 SRC_URI="x86? ( mirror://planeshift/PlaneShift-v${PV}-x86.bin )
10         amd64? ( mirror://planeshift/PlaneShift-v${PV}-x64.bin )"
11
12 LICENSE="GPL-3 PlaneShift"
13 SLOT="0"
14 KEYWORDS="-* ~amd64 ~x86"
15 IUSE=""
16
17 RESTRICT="strip"
18
19 src_unpack() {
20         cp -L "${DISTDIR}/${A}" "${WORKDIR}" || die "Copy ${A} to ${WORKDIR}"
21         chmod +x "${WORKDIR}/${A}" || die "chmod die"
22 }
23
24 src_install() {
25         "${WORKDIR}"/${A} \
26                 --mode unattended \
27                 --perms yes \
28                 --usergroup games \
29                 --prefix "${D}/${GAMES_PREFIX_OPT}" || die "Installer of Planeshift die"
30
31         rm "${D}/${GAMES_PREFIX_OPT}"/PlaneShift/psupdater
32         rm "${D}/${GAMES_PREFIX_OPT}"/PlaneShift/psupdater.bin
33         rm "${D}/${GAMES_PREFIX_OPT}"/PlaneShift/uninstall
34
35         games_make_wrapper psclient "${GAMES_PREFIX_OPT}/PlaneShift/psclient"
36         make_desktop_entry psclient "Play PlaneShift"
37
38         games_make_wrapper pssetup "${GAMES_PREFIX_OPT}/PlaneShift/pssetup"
39         make_desktop_entry pssetup "PlaneShift setup"
40 }