]> Pileus Git - ~andy/sunrise/blob - games-rpg/mi3-demo/mi3-demo-1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / games-rpg / mi3-demo / mi3-demo-1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="The Curse of Monkey Island (interactive demo)"
8 HOMEPAGE="http://www.lucasarts.com/products/monkey/default.htm"
9 SRC_URI="http://gentooexperimental.org/~unlord/${PN}.rar"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="|| (
19         app-arch/unrar
20         app-arch/rar )"
21
22 S=${WORKDIR}
23 dir=${GAMES_DATADIR}/${PN}
24
25 src_install() {
26         insinto "${dir}"
27         doins COMI.LA0 COMI.LA1 || die "doins failed"
28         doins -r RESOURCE || die "doins -r failed"
29
30         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" comi"
31         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
32         make_desktop_entry ${PN} "Monkey Island 3 (Demo)" ${PN}.png
33
34         prepgamesdirs
35 }