]> Pileus Git - ~andy/sunrise/blob - games-rpg/mi1-demo/mi1-demo-1.ebuild
games-strategy/freesynd: in main tree
[~andy/sunrise] / games-rpg / mi1-demo / mi1-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="The Secret of Monkey Island (interactive demo)"
8 HOMEPAGE="http://www.worldofmi.com/thegames/monkey1/"
9 SRC_URI="http://gentooexperimental.org/~unlord/${PN}.zip"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="app-arch/unzip"
19
20 S=${WORKDIR}
21 dir=${GAMES_DATADIR}/${PN}
22
23 src_install() {
24         insinto "${dir}"
25         doins *.{LEC,LFL} || die "doins failed"
26
27         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" monkey"
28         doicon "${FILESDIR}/${PN}.png" || die "newicon failed"
29         make_desktop_entry ${PN} "Monkey Island 1 (Demo)" ${PN}.png
30
31         prepgamesdirs
32 }