]> Pileus Git - ~andy/sunrise/blob - games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / games-rpg / lipsofsuna / lipsofsuna-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 EGIT_REPO_URI="git://lipsofsuna.git.sourceforge.net/gitroot/lipsofsuna/lipsofsuna"
8 EGIT_PROJECT="lipsofsuna"
9 inherit eutils games waf-utils git-2
10
11 DESCRIPTION="Tongue-in-cheek dungeon crawl game. Client and Server"
12 HOMEPAGE="http://lipsofsuna.org/"
13 SRC_URI=""
14
15 LICENSE="LGPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 DEPEND="dev-db/sqlite:3
21         >=dev-lang/lua-5.1.0
22         media-libs/flac
23         >=media-libs/glew-1.5
24         >=media-libs/libsdl-1.2
25         media-libs/libvorbis
26         media-libs/libogg
27         media-libs/mesa
28         media-libs/openal
29         >=media-libs/sdl-ttf-2.0
30         >=net-libs/enet-1
31         >=net-misc/curl-3
32         sci-physics/bullet"
33 RDEPEND="${DEPEND}"
34
35 src_configure() {
36         waf-utils_src_configure \
37                 --relpath=false --optimize=true \
38                 --bindir="${GAMES_BINDIR}" \
39                 --datadir="${GAMES_DATADIR}"
40 }
41
42 src_install() {
43         dogamesbin .build/${PN} || die "Installation of gamesbinary failed"
44         insinto "${GAMES_DATADIR}"/${PN}/
45         doins -r data/* || die "Installation of game data failed"
46         doicon misc/${PN}.svg || die "Installation of Icon failed"
47         domenu misc/${PN}.desktop || die "Installation of desktop file failed"
48         prepgamesdirs
49 }