]> Pileus Git - ~andy/sunrise/blob - games-rpg/ihnm-demo/ihnm-demo-1.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / games-rpg / ihnm-demo / ihnm-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="I Have No Mouth, and I Must Scream (interactive demo)"
8 HOMEPAGE="http://harlanellison.com/herc.htm#ihnm"
9 SRC_URI="http://gentooexperimental.org/~unlord/scream.rar"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.11.0"
18 DEPEND="|| (
19         app-arch/unrar
20         app-arch/rar )"
21
22 S=${WORKDIR}
23
24 src_install() {
25         local dir=${GAMES_DATADIR}/${PN}
26         insinto "${dir}"
27         doins MUSIC.RES SCREAM.RES SCRIPTS.RES SFX.RES VOICESD.RES || die "doins failed"
28
29         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" ihnm-demo"
30         make_desktop_entry ${PN} "I Have No Mouth, and I Must Scream (Demo)"
31
32         prepgamesdirs
33 }