]> Pileus Git - ~andy/sunrise/blob - games-rpg/ft/ft-1.ebuild
app-misc/japanese-vocabulary: Adding ~amd64 keyword, fixing qt deps properly
[~andy/sunrise] / games-rpg / ft / ft-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games cdrom
6
7 DESCRIPTION="Full Throttle"
8 HOMEPAGE="http://wiki.scummvm.org/index.php/Full_Throttle"
9
10 LICENSE="freedist"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 RESTRICT="strip"
15
16 RDEPEND=">=games-engines/scummvm-0.2.0"
17
18 src_install() {
19         local dir=${GAMES_DATADIR}/${PN}
20
21         insinto "${dir}"
22
23         cdrom_get_cds RESOURCE/FT.EXE
24         einfo "Copying files from CD..."
25
26         doins ${CDROM_ROOT}/RESOURCE/FT.{LA0,LA1} \
27                 ${CDROM_ROOT}/RESOURCE/MONSTER.SOU || die "doins failed"
28         doins -r ${CDROM_ROOT}/RESOURCE/DATA \
29                 ${CDROM_ROOT}/RESOURCE/VIDEO || die "doins -r failed"
30
31         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" ft"
32         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
33         make_desktop_entry ${PN} "Full Throttle" ${PN}.png
34
35         prepgamesdirs
36 }