]> Pileus Git - ~andy/sunrise/blob - games-rpg/dott/dott-1.ebuild
sci-libs/rsl: Update to RSL 1.43
[~andy/sunrise] / games-rpg / dott / dott-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games cdrom
6
7 DESCRIPTION="Day of the Tentacle"
8 HOMEPAGE="http://wiki.scummvm.org/index.php/Day_of_the_Tentacle"
9
10 LICENSE="freedist"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 RESTRICT="strip"
15
16 RDEPEND=">=games-engines/scummvm-0.2.0"
17
18 S=${WORKDIR}
19
20 src_install() {
21         local dir=${GAMES_DATADIR}/${PN}
22         insinto "${dir}"
23
24         cdrom_get_cds DOTT.EXE
25         einfo "Copying files from CD..."
26         doins ${CDROM_ROOT}/DOTT/MONSTER.SOU \
27                 ${CDROM_ROOT}/DOTT/TENTACLE.000 \
28                 ${CDROM_ROOT}/DOTT/TENTACLE.001 || die "doins failed"
29
30         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" tentacle"
31         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
32         make_desktop_entry ${PN} "Day of the Tentacle" ${PN}.png
33
34         prepgamesdirs
35 }