]> Pileus Git - ~andy/sunrise/blob - games-rpg/bs2-demo/bs2-demo-1.ebuild
app-misc/2gis: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / games-rpg / bs2-demo / bs2-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Broken Sword 2: The Smoking Mirror (interactive demo)"
8 HOMEPAGE="http://www.revolution.co.uk/_display.php?id=15"
9 SRC_URI="http://files.5star-network.com/Games/${PN}.zip
10         ftp://ftp.planetmirror.com/pub/gameworld/demos/${PN}.zip
11         http://gentooexperimental.org/~unlord/${PN}.zip
12         mirror://sourceforge/scummvm/Sword2_Demo_Cutscenes.zip
13         http://gentooexperimental.org/~unlord/Sword2_Demo_Cutscenes.zip"
14
15 LICENSE="freedist"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19 RESTRICT="strip"
20
21 RDEPEND=">=games-engines/scummvm-0.10.0"
22 DEPEND="app-arch/unzip"
23
24 S=${WORKDIR}
25 dir=${GAMES_DATADIR}/${PN}
26
27 src_install() {
28         insinto "${dir}"
29         doins *.{clu,CLU,inf,tab,dxa,fla} || die "doins failed"
30
31         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" sword2demo"
32         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
33         make_desktop_entry ${PN} "Broken Sword 2 (Demo)" ${PN}.png
34
35         prepgamesdirs
36 }