]> Pileus Git - ~andy/sunrise/blob - games-rpg/bs1-demo/bs1-demo-1.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / games-rpg / bs1-demo / bs1-demo-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Broken Sword 1: The Shadow of the Templars (interactive demo)"
8 HOMEPAGE="http://www.revolution.co.uk/_display.php?id=14"
9 SRC_URI="http://gentooexperimental.org/~unlord/bs1-demo.rar
10         http://gentooexperimental.org/~unlord/Sword1_Demo_Cutscenes.zip"
11
12 LICENSE="freedist"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 RESTRICT="strip"
17
18 RDEPEND=">=games-engines/scummvm-0.10.0"
19 DEPEND="|| (
20         app-arch/unrar
21         app-arch/rar )
22         app-arch/unzip"
23
24 S=${WORKDIR}
25 dir=${GAMES_DATADIR}/${PN}
26
27 src_install() {
28         insinto "${dir}"
29         doins SWORD_INSTALL/CLUSTERS/*.{CLU,RIF} *.{dxa,fla} || die "doins failed"
30         doins -r SWORD_INSTALL/{MUSIC,SPEECH} || die "doins -r failed"
31
32         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" sword1demo"
33         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
34         make_desktop_entry ${PN} "Broken Sword 1 (Demo)" ${PN}.png
35
36         prepgamesdirs
37 }