]> Pileus Git - ~andy/sunrise/blob - games-puzzle/pythonsudoku/pythonsudoku-0.13.ebuild
dev-libs/libserial: Adding ~amd64 keyword
[~andy/sunrise] / games-puzzle / pythonsudoku / pythonsudoku-0.13.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit games distutils
12
13 DESCRIPTION="A graphical and text-based sudoku game"
14 HOMEPAGE="http://pythonsudoku.sourceforge.net/"
15 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~ppc ~x86"
20 IUSE=""
21
22 DEPEND="app-arch/unzip"
23 RDEPEND="dev-python/pygtk
24         dev-python/reportlab
25         dev-python/imaging"
26
27 src_prepare() {
28         sed \
29                 -e "s:/usr/games:/usr/games/bin:g" \
30                 -i setup.cfg || die
31 }
32
33 src_install() {
34         newgamesbin pysdk.py pysdk || die "newgamesbin failed"
35         distutils_src_install
36
37         dohtml -r doc/* || die
38         doman doc/pysdk.6 || die
39         dodoc doc/*.txt || die
40
41         prepgamesdirs
42
43         insinto /etc/games/pythonsudoku
44         doins pysdk.cfg || die
45 }