]> Pileus Git - ~andy/sunrise/blob - games-puzzle/pythonsudoku/pythonsudoku-0.12.4.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / games-puzzle / pythonsudoku / pythonsudoku-0.12.4.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games distutils
6
7 DESCRIPTION="A graphical and text-based sudoku game"
8 HOMEPAGE="http://pythonsudoku.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND="dev-python/pygtk
18         dev-python/reportlab
19         dev-python/imaging"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         sed -i \
25                 -e 's#\(syscfg[ \t]*\)=.*#\1= /etc/games/pythonsudoku/pysdk.cfg#' \
26                 -e 's#\(install-scripts[ \t]*\)=.*#\1= /usr/games/bin#' \
27                 pythonsudoku/platform.cfg setup.cfg || die "fixing configfile path failed"
28 }
29
30 src_install() {
31         newgamesbin pysdk.py pysdk || die "newgamesbin failed"
32         distutils_src_install
33
34         dohtml -r doc/*
35         doman doc/pysdk.6
36         dodoc doc/*.txt
37
38         prepgamesdirs
39
40         insinto /etc/games/pythonsudoku
41         doins pysdk.cfg
42 }