]> Pileus Git - ~andy/sunrise/blob - games-puzzle/hex-a-hop/hex-a-hop-1.1.0.ebuild
sci-visualization/tulip: Properly fix qt deps
[~andy/sunrise] / games-puzzle / hex-a-hop / hex-a-hop-1.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit base eutils games
8
9 DESCRIPTION="A hexagonal tile-based puzzle game"
10 HOMEPAGE="http://hexahop.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/hexahop/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="pango sound"
17
18 DEPEND="media-libs/libsdl
19         media-libs/sdl-image
20         sound? ( media-libs/sdl-mixer[vorbis] )
21         pango? ( media-libs/sdl-pango )
22         !pango? ( media-libs/sdl-ttf )"
23
24 RDEPEND="${DEPEND}"
25
26 DOCS=( AUTHORS ChangeLog )
27
28 src_configure() {
29         # The build system is broken. Both --enable-sound and --disable-sound
30         # disable sound. Both --enable-sdlttf and --disable-sdlttf disable sdlttf.
31         egamesconf \
32                 --disable-debug \
33                 $(use !sound && echo --disable-sound) \
34                 $(use pango && echo --disable-sdlttf)
35 }
36
37 src_install () {
38         base_src_install
39
40         if ! use sound; then
41                 rm -f "${D}/${GAMES_DATADIR}"/*.ogg || die
42         fi
43
44         newicon data/icon.bmp ${PN}.bmp
45         make_desktop_entry ${PN} Hex-a-Hop /usr/share/pixmaps/${PN}.bmp
46         prepgamesdirs
47 }