]> Pileus Git - ~andy/sunrise/blob - games-puzzle/OsmosDemo/OsmosDemo-1.6.0.ebuild
media-video/ucview: fix metadata.xml
[~andy/sunrise] / games-puzzle / OsmosDemo / OsmosDemo-1.6.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit games
8
9 DESCRIPTION="Simple, ambient, nice-looking growing game"
10 HOMEPAGE="http://www.hemispheregames.com/osmos/"
11 SRC_URI="http://www.hemispheregames.com/blog/wp-content/uploads/2010/04/${PN}_${PV}.tar.gz"
12
13 LICENSE="${PN}"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 -*"
16 IUSE=""
17
18 RDEPEND="media-libs/freetype
19         media-libs/libvorbis
20         media-libs/openal
21         x11-libs/libX11
22         virtual/opengl"
23
24 S=${WORKDIR}/${PN}
25 QA_PRESTRIPPED="/opt/OsmosDemo/OsmosDemo.bin32
26         /opt/OsmosDemo/OsmosDemo.bin64"
27
28 src_prepare() {
29         rm eula.txt OsmosDemo || die
30         if use amd64 ; then
31                 MY_BIN=${PN}.bin64
32                 rm ${PN}.bin32 || die
33         fi
34         if use x86 ; then
35                 MY_BIN=${PN}.bin32
36                 rm ${PN}.bin64 || die
37         fi
38 }
39
40 src_install() {
41         local my_dest=/opt/${PN}
42         insinto "${my_dest}"
43         doins -r . || die
44         fperms ug+x "${my_dest}"/${MY_BIN} || die
45
46         games_make_wrapper ${PN} ./${MY_BIN} "${my_dest}"
47         make_desktop_entry "${GAMES_BINDIR}"/${PN} ${PN} "${my_dest}"/Icons/128x128.png Game
48         prepgamesdirs "${my_dest}"
49 }