]> Pileus Git - ~andy/sunrise/blob - games-misc/limbs-off/limbs-off-9999.ebuild
dev-db/cppdb: Adding ~amd64 keyword
[~andy/sunrise] / games-misc / limbs-off / limbs-off-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit autotools git-2 games
8
9 DESCRIPTION="Gratis Free Software fighting game"
10 HOMEPAGE="http://plaimi.net/games/"
11 EGIT_REPO_URI="https://github.com/stiell/${PN}.git
12         git://github.com/stiell/${PN}.git"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 RDEPEND="
20         media-libs/fontconfig
21         media-libs/libpng:0
22         media-libs/libsdl[opengl]
23         media-libs/sdl-ttf
24         virtual/opengl
25         "
26
27 DEPEND="${RDEPEND}
28         virtual/pkgconfig
29         "
30
31 src_unpack() {
32         git-2_src_unpack
33 }
34
35 src_prepare() {
36         eautoreconf
37 }
38
39 src_configure() {
40         egamesconf \
41                 --with-icondir=/usr/share/pixmaps \
42                 --with-desktopdir=/usr/share/applications
43 }
44
45 src_install() {
46         dodoc HACKING TODO || die
47         emake DESTDIR="${D}" install || die
48         prepgamesdirs
49 }