]> Pileus Git - ~andy/sunrise/blob - games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / games-misc / limbs-off / limbs-off-1.0_alpha2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit autotools git-2 games
8
9 DESCRIPTION="Gratis Free Software fighting game"
10 HOMEPAGE="http://plaimi.net/games/"
11 EGIT_REPO_URI="https://github.com/stiell/${PN}.git
12         git://github.com/stiell/${PN}.git"
13 EGIT_COMMIT="c402478ff4c93caa75219527e0a59ae5061ce66f"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 RDEPEND="
21         media-libs/fontconfig
22         media-libs/libpng:0
23         media-libs/libsdl[opengl]
24         media-libs/sdl-ttf
25         virtual/opengl
26         "
27
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig
30         "
31
32 src_unpack() {
33         git-2_src_unpack
34 }
35
36 src_prepare() {
37         eautoreconf
38 }
39
40 src_configure() {
41         egamesconf \
42                 --with-icondir=/usr/share/pixmaps \
43                 --with-desktopdir=/usr/share/applications
44 }
45
46 src_install() {
47         dodoc HACKING TODO || die
48         emake DESTDIR="${D}" install || die
49         prepgamesdirs
50 }