]> Pileus Git - ~andy/sunrise/blob - games-fps/vavoom-textures/vavoom-textures-1.1.ebuild
vavoom-textures: Adjust 'find' calls to be POSIX-compliant.
[~andy/sunrise] / games-fps / vavoom-textures / vavoom-textures-1.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 # For some package the version hasn't been bumped
8 OLD_PV="1.0"
9
10 DESCRIPTION="Enhanced graphics and textures for Vavoom"
11 HOMEPAGE="http://www.vavoom-engine.com/"
12
13 SRC_URI="doom1? ( mirror://sourceforge/vavoom/vtextures-doom-${PV}.zip
14                                         mirror://sourceforge/vavoom/vtextures-doom1-${PV}.zip )
15         doom2? ( mirror://sourceforge/vavoom/vtextures-doom-${PV}.zip
16                                 mirror://sourceforge/vavoom/vtextures-doom2-${PV}.zip )
17         heretic? ( mirror://sourceforge/vavoom/vtextures-heretic-${OLD_PV}.zip )
18         hexen? ( mirror://sourceforge/vavoom/vtextures-hexen-${OLD_PV}.zip )
19         plutonia? ( mirror://sourceforge/vavoom/vtextures-doom-${PV}.zip
20                                 mirror://sourceforge/vavoom/vtextures-doom2-${PV}.zip
21                                 mirror://sourceforge/vavoom/vtextures-plutonia-${OLD_PV}.zip )
22         tnt? (  mirror://sourceforge/vavoom/vtextures-doom-${PV}.zip
23                         mirror://sourceforge/vavoom/vtextures-doom2-${PV}.zip
24                         mirror://sourceforge/vavoom/vtextures-tnt-${OLD_PV}.zip )
25         !doom1? ( !doom2? ( !heretic? ( !hexen? ( !plutonia? ( !tnt? (
26                 mirror://sourceforge/vavoom/vtextures-doom-${PV}.zip
27                 mirror://sourceforge/vavoom/vtextures-doom1-${PV}.zip
28                 mirror://sourceforge/vavoom/vtextures-doom2-${PV}.zip
29                 mirror://sourceforge/vavoom/vtextures-heretic-${OLD_PV}.zip
30                 mirror://sourceforge/vavoom/vtextures-hexen-${OLD_PV}.zip
31                 mirror://sourceforge/vavoom/vtextures-plutonia-${OLD_PV}.zip
32                 mirror://sourceforge/vavoom/vtextures-tnt-${OLD_PV}.zip
33                 ) ) ) ) ) )"
34
35 LICENSE="as-is"
36 SLOT="0"
37 KEYWORDS="~amd64 ~x86"
38 IUSE="doom1 doom2 heretic hexen plutonia tnt"
39
40 RDEPEND="games-fps/vavoom"
41 DEPEND="app-arch/unzip"
42
43 S=${WORKDIR}
44
45 src_unpack() {
46         unpack ${A}
47
48         cd "${S}"
49         # Rename docs and remove duplicates
50         for u in `ls -1 basev` ; do
51                 case "${u}" in
52                         "doom")
53                                 cp "basev/${u}/xgfx.txt" "${u}-gfx.txt"
54                                 cp "basev/${u}/xwalls.txt" "${u}-walls.txt"
55                                 cp "basev/${u}/xflats.txt" "${u}-flats.txt"
56                                 ;;
57                         "heretic")
58                                 cp "basev/${u}/xgfx.txt" "${u}-textures.txt"
59                                 ;;
60                         "hexen")
61                                 cp "basev/${u}/xgfx.txt" "${u}-textures.txt"
62                                 ;;
63                 esac
64         done
65
66         # Delete all stale docs
67         find basev/ -name '*.txt' -exec rm -f {} + || die
68 }
69
70 src_install() {
71         dodoc *.txt || die "dodoc failed"
72
73         cd basev
74         insinto "${GAMES_DATADIR}/vavoom/basev/"
75         doins -r * || die "doins failed"
76
77         prepgamesdirs
78 }