]> Pileus Git - ~andy/sunrise/blob - games-fps/vavoom-music/vavoom-music-1.0.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / games-fps / vavoom-music / vavoom-music-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="Enhanced music for Vavoom"
8 HOMEPAGE="http://www.vavoom-engine.com/"
9
10 SRC_URI="doom1? ( mirror://sourceforge/vavoom/vmusic-doom1-${PV}.zip )
11         doom2? ( mirror://sourceforge/vavoom/vmusic-doom2-${PV}.zip )
12         heretic? ( mirror://sourceforge/vavoom/vmusic-heretic-${PV}.zip )
13         hexen? ( mirror://sourceforge/vavoom/vmusic-hexen-${PV}.zip )
14         plutonia? ( mirror://sourceforge/vavoom/vmusic-doom1-${PV}.zip
15                                 mirror://sourceforge/vavoom/vmusic-doom2-${PV}.zip
16                                 mirror://sourceforge/vavoom/vmusic-plutonia-${PV}.zip )
17         tnt? (  mirror://sourceforge/vavoom/vmusic-doom2-${PV}.zip
18                         mirror://sourceforge/vavoom/vmusic-tnt-${PV}.zip )
19         !doom1? ( !doom2? ( !heretic? ( !hexen? ( !plutonia? ( !tnt? (
20                 mirror://sourceforge/vavoom/vmusic-doom1-${PV}.zip
21                 mirror://sourceforge/vavoom/vmusic-doom2-${PV}.zip
22                 mirror://sourceforge/vavoom/vmusic-heretic-${PV}.zip
23                 mirror://sourceforge/vavoom/vmusic-hexen-${PV}.zip
24                 mirror://sourceforge/vavoom/vmusic-plutonia-${PV}.zip
25                 mirror://sourceforge/vavoom/vmusic-tnt-${PV}.zip
26                 ) ) ) ) ) )"
27
28 LICENSE="as-is"
29 SLOT="0"
30 KEYWORDS="~amd64 ~x86"
31 IUSE="doom1 doom2 heretic hexen plutonia tnt"
32
33 RDEPEND="games-fps/vavoom"
34 DEPEND="app-arch/unzip"
35
36 S=${WORKDIR}
37
38 src_unpack() {
39         local game
40
41         unpack ${A}
42
43         for x in `find basev/ -name "xmusic.txt" -print` ; do
44                 game=$(echo ${x} | awk -F '/' {'print $2'})
45                 mv ${x} ${game}.txt || die "mv ${game}.txt failed"
46         done
47 }
48
49 src_install() {
50         dodoc *.txt || die "dodoc failed"
51
52         insinto "${GAMES_DATADIR}/vavoom/"
53         doins -r basev || die "doins failed"
54
55         prepgamesdirs
56 }