]> Pileus Git - ~andy/sunrise/blob - games-fps/postal2mp/postal2mp-1409.ebuild
dev-db/dabo: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / games-fps / postal2mp / postal2mp-1409.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 inherit eutils games multilib
7
8 DESCRIPTION="Postal 2: Share the Pain - Free Multiplayer Edition"
9 HOMEPAGE="http://icculus.org/news/news.php?id=4419"
10 SRC_URI="http://0day.icculus.org/postal2/Postal2STP-FreeMP-linux.tar.bz2 -> ${P}.tar.bz2"
11
12 LICENSE="postal2stp-freemp"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 RESTRICT="strip"
17 PROPERTIES="interactive"
18
19 RDEPEND="virtual/opengl
20         amd64? ( app-emulation/emul-linux-x86-sdl )
21         x86? (
22                 media-libs/libsdl[X,opengl]
23                 media-libs/openal
24         )"
25
26 GAMES_CHECK_LICENSE="yes"
27
28 S=${WORKDIR}/Postal2STP-FreeMP-linux
29
30 src_install() {
31         has_multilib_profile && ABI=x86
32
33         dir=${GAMES_PREFIX_OPT}/${PN}
34
35         insinto "${dir}"
36         doins -r Animations KarmaData Maps Music Sounds \
37                  StaticMeshes System Textures Web || die "doins failed"
38         dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so || die
39         dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 || die
40
41         fperms +x "${dir}"/System/postal2-bin || die "fperms failed"
42
43         games_make_wrapper ${PN} ./postal2-bin "${dir}"/System .
44         newicon postal2.xpm ${PN}.xpm || die
45         make_desktop_entry ${PN} "Postal 2 (Free MultiPlayer Ed.)"
46
47         prepgamesdirs
48 }