]> Pileus Git - ~andy/sunrise/blob - games-fps/hexen2-lights/hexen2-lights-1.ebuild
net-misc/fatrat: Fix qt deps
[~andy/sunrise] / games-fps / hexen2-lights / hexen2-lights-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 MY_PN="hexen2"
8
9 DESCRIPTION="Colored lighting data for Hexen 2"
10 HOMEPAGE="http://uhexen2.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/u${MY_PN}/${MY_PN}-lit_files.tgz"
12
13 LICENSE="as-is"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 S=${WORKDIR}
19
20 src_install() {
21         local my_dir=${GAMES_DATADIR}/${MY_PN}
22         insinto "${my_dir}"
23         doins -r data1 || die
24
25         # The 3 demo maps are also in the demo data.
26         dodir "${my_dir}"/demo/data1/maps
27         local my_i
28         for my_i in 1 2 3 ; do
29                 dosym "${my_dir}"/data1/maps/demo${my_i}.lit  "${my_dir}"/demo/data1/maps || die
30         done
31
32         dodoc *.txt || die
33
34         prepgamesdirs
35 }
36
37 pkg_postinst() {
38         games_pkg_postinst
39
40         if ! has_version "games-fps/uhexen2" ; then
41                 elog "This is just lighting data. To play, emerge a client"
42                 elog "such as uhexen2."
43         fi
44 }