]> Pileus Git - ~andy/sunrise/blob - games-engines/dagii/dagii-0.4.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / games-engines / dagii / dagii-0.4.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="a reimplementation of Sierra's Adventure Game Interpreter"
8 HOMEPAGE="http://www.dagii.org/"
9 SRC_URI="http://www.dagii.org/dist/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~ppc ~x86 ~x86-fbsd"
14 IUSE="png"
15
16 DEPEND="png? ( >=media-libs/libpng-1.2.8 )
17         >=media-libs/libsdl-1.2.9
18         >=sys-libs/zlib-1.2.0"
19 RDEPEND="${DEPEND}"
20
21 src_compile() {
22         egamesconf $(use_enable png libpng ) || die "econf failed"
23         emake dep || die "emake dep failed"
24         emake || die "emake failed"
25 }
26
27 src_install() {
28         dogamesbin src/${PN}
29         dodoc README.txt
30         doicon "${FILESDIR}/${PN}.xpm"
31         make_desktop_entry ${PN} ${PN} ${PN}.xpm "Game;AdventureGame"
32         prepgamesdirs
33 }
34
35 pkg_postinst() {
36         elog "Dagii looks for games either in the user's current directory"
37         elog "or in a location passed as a path in the command line"
38         elog "For example: \"$ dagii /usr/share/games/kq3\""
39         elog "Also, dagii can play games which are stored in .zip archives."
40         echo
41         games_pkg_postinst
42 }