]> Pileus Git - ~andy/sunrise/blob - games-emulation/lxdream/lxdream-0.9.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / games-emulation / lxdream / lxdream-0.9.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils games
8
9 DESCRIPTION="An emulator for the Sega Dreamcast system"
10 HOMEPAGE="http://www.lxdream.org/"
11 SRC_URI="http://www.lxdream.org/count.php?file=${P}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug esd profile pulseaudio sdl"
17
18 RDEPEND="media-libs/alsa-lib
19         media-libs/libpng
20         esd? ( media-sound/esound )
21         pulseaudio? ( media-sound/pulseaudio )
22         sdl? ( media-libs/libsdl )
23         virtual/opengl
24         x11-libs/gtk+:2"
25
26 DEPEND="${RDEPEND}
27         dev-util/pkgconfig
28         sys-devel/gettext
29         virtual/os-headers"
30
31 src_configure() {
32         econf \
33                 $(use_enable debug trace) \
34                 $(use_enable debug watch) \
35                 $(use_enable profile profiled) \
36                 $(use_with esd) \
37                 $(use_with pulseaudio pulse) \
38                 $(use_with sdl)
39 }
40
41 src_install() {
42         emake DESTDIR="${D}" install || die "install failed"
43         dodoc ChangeLog NEWS README || die "dodoc failed"
44         doicon pixmaps/${PN}.png || die "doicon failed"
45         domenu ${PN}.desktop || die "make_desktop_entry failed"
46         prepgamesdirs
47 }