]> Pileus Git - ~andy/sunrise/blob - games-emulation/gr-lida/gr-lida-0.4.0.ebuild
games-util/playonlinux: Drop some unneeded lines and remove LICENSE from dodoc
[~andy/sunrise] / games-emulation / gr-lida / gr-lida-0.4.0.ebuild
1 # Copyright 2006-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit qt4
6
7 MY_P="GR-lida-${PV}"
8 S="${WORKDIR}"/"${MY_P}"
9
10 DESCRIPTION="Frontend for scummvm and dosbox"
11 HOMEPAGE="http://www.laisladelabandoware.es"
12 SRC_URI="http://dl.sharesource.org/grlida/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="dosbox scummvm"
18
19 DEPEND="$(qt4_min_version 4.3)"
20
21 RDEPEND="${DEPEND}
22         dosbox? ( games-emulation/dosbox )
23         scummvm? ( games-engines/scummvm )"
24
25 QT4_BUILT_WITH_USE_CHECK="gif jpeg png sqlite3"
26
27 src_compile(){
28         eqmake4 "${PN}".pro || die
29         emake || die "Compile Failed"
30 }
31
32 src_install(){
33         emake INSTALL_ROOT="${D}" install || die "Install Failed"
34 }
35
36 pkg_postinst(){
37         einfo "The GUI is by default in Spanish."
38         einfo "If you need it, English is available on the Options Menu."
39 }