]> Pileus Git - ~andy/sunrise/blob - games-arcade/vodovod/vodovod-1.10.ebuild
app-admin/noobjuice-viewer: Fix qt deps, EAPI bump
[~andy/sunrise] / games-arcade / vodovod / vodovod-1.10.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="A free cross-platform pipe connecting game"
8 HOMEPAGE="http://home.gna.org/vodovod/"
9 SRC_URI="http://download.gna.org/${PN}/${P}-src.tar.gz"
10
11 S=${WORKDIR}/${P}-src
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="media-libs/libsdl
18                 media-libs/sdl-mixer
19                 media-libs/sdl-image"
20 RDEPEND=${DEPEND}
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         sed -e 's:"\(data/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i *.cpp || die
26         epatch "${FILESDIR}/${P}-gcc4.3.patch"
27 }
28
29 src_install() {
30         dogamesbin "${PN}" || die "dogamesbin failed"
31         insinto "${GAMES_DATADIR}/${PN}/data"
32         doins data/* || die "doins failed"
33         #doicon ${DISTDIR}/${PN}.png
34         make_desktop_entry ${PN} "Vodovod"
35         prepgamesdirs
36 }