]> Pileus Git - ~andy/sunrise/blob - games-arcade/tuxanci/tuxanci-0.07.ebuild
games-arcade/tuxanci: New ebuild, created by myself
[~andy/sunrise] / games-arcade / tuxanci / tuxanci-0.07.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $ 
4
5 inherit games toolchain-funcs
6
7 DESCRIPTION="First Cushion Shooter! A remake of well-known Czech game Bulanci."
8 SRC_URI="http://tuxanci.tuxportal.cz/releases/${P}.tar.bz2"
9 HOMEPAGE="http://tuxanci.tuxportal.cz"
10
11 KEYWORDS="~x86"
12 LICENSE="GPL-2"
13 SLOT="0"
14
15 RDEPEND="media-libs/libsdl
16         media-libs/sdl-ttf
17         media-libs/sdl-image
18         media-libs/sdl-mixer"
19
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         # quick fix for English localization
25         sed -i -e "s/End game/Quit!/" lang/en.lang || die "sed failed"
26 }
27
28 src_compile() {
29         emake CC=$(tc-getCC) || die "emake failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "Installation failed."
34         dodoc README ChangeLog
35         prepgamesdirs
36 }