]> Pileus Git - ~andy/sunrise/blob - games-arcade/snake/snake-0.5.2.ebuild
net-misc/wolman: Fix qt deps
[~andy/sunrise] / games-arcade / snake / snake-0.5.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils games toolchain-funcs
8
9 DESCRIPTION="snake like game"
10 HOMEPAGE="http://www.hs.no-ip.info/software/snake.html"
11 SRC_URI="http://www.hs.no-ip.info/software/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 DEPEND="media-libs/libsdl[alsa,X]
18         media-libs/sdl-gfx
19         media-libs/sdl-image[png]
20         media-libs/sdl-mixer
21         media-libs/sdl-ttf"
22 RDEPEND=${DEPEND}
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${P}-{clean-up-Makefile,qa-warnings}.patch
26 }
27
28 src_compile() {
29         emake CC=$(tc-getCXX) || die "emake failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "install failed"
34         prepgamesdirs
35 }