]> Pileus Git - ~andy/sunrise/blob - games-arcade/openalchemist/openalchemist-0.3.ebuild
Use pkgconfig virtual.
[~andy/sunrise] / games-arcade / openalchemist / openalchemist-0.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils games
8
9 DESCRIPTION="NaturalChimie clone written with clanlib"
10 HOMEPAGE="http://www.openalchemist.com/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND=">=dev-games/clanlib-0.8.0[opengl,sdl]"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 S=${WORKDIR}/${P}-src
23
24 DOCS="NEWS README TODO ChangeLog"
25
26 src_prepare() {
27         epatch "${FILESDIR}/${P}-gentoo.patch"
28 }
29
30 src_install() {
31         dogamesbin build/${PN} || die "dogamesbin failed"
32         dogamesbin ${PN}-config || die "dogamesbin config failed"
33
34         insinto "${GAMES_DATADIR}"/${PN}
35         doins -r data skins || die "doins failed"
36
37         dodoc ${DOCS} || die "dodoc failed"
38
39         newicon data/logo.png openalchemist.png
40         newicon data/logo_svg.svg openalchemist.svg
41         make_desktop_entry ${PN} OpenAlchemist ${PN}
42
43         prepgamesdirs
44 }