]> Pileus Git - ~andy/sunrise/blob - games-arcade/flyhard/flyhard-0.42.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / games-arcade / flyhard / flyhard-0.42.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils autotools games
8
9 DESCRIPTION="A game resembling Thrust, but with lots of shooting and puzzles"
10 HOMEPAGE="http://www.markboyd.me.uk/games/flyhard/flyhard.html" # returns 404
11 SRC_URI="http://mirror.amdmi3.ru/distfiles/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="media-libs/libpng:0
19         media-libs/libsdl[audio]
20         media-libs/sdl-mixer[wav]"
21 DEPEND="${RDEPEND}
22         dev-libs/boost"
23
24 src_prepare() {
25         epatch "${FILESDIR}/${P}-Makefile.patch"
26         # Needed for automake-1.13
27         mv configure.in configure.ac || die
28         eautoreconf
29 }
30
31 src_install() {
32         default
33         prepgamesdirs
34 }