]> Pileus Git - ~andy/sunrise/blob - games-action/openliero/openliero-20080508.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / games-action / openliero / openliero-20080508.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Almost exact clone of Liero"
8 HOMEPAGE="http://open.liero.be/"
9 SRC_URI="http://stepien.cc/~jan/gentoo/distfiles/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="media-libs/libsdl
17         media-libs/sdl-mixer"
18 DEPEND="${RDEPEND}
19         dev-util/ftjam"
20
21 src_unpack() {
22         unpack ${A}
23         epatch "${FILESDIR}"/${P}-gcc-4.3.patch
24 }
25
26 src_compile() {
27         jam -qa || die "jam failed"
28 }
29
30 src_install() {
31         dogamesbin openliero || die "dogamesbin failed"
32         prepgamesdir
33 }
34
35 pkg_postinst() {
36         elog "${PN} requires the original Liero files in order to run properly."
37         elog "Visit http://www.liero.be/ and download a Liero package. Unpack it"
38         elog "and run ${PN} inside a directory with Liero."
39 }