]> Pileus Git - ~andy/sunrise/blob - games-action/minetest_game/minetest_game-0.4_pre20120408.ebuild
sci-visualization/tulip: Properly fix qt deps
[~andy/sunrise] / games-action / minetest_game / minetest_game-0.4_pre20120408.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit git-2 games
8
9 DESCRIPTION="Building single/multiplayer game (game)"
10 HOMEPAGE="http://c55.me/minetest/"
11 SRC_URI=""
12
13 EGIT_REPO_URI="git://github.com/celeron55/${PN}.git"
14 EGIT_COMMIT="${PV%_pre*}.dev-${PV#*_pre}"
15
16 LICENSE="GPL-2 CC-BY-SA-3.0"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND="games-action/minetest"
22 DEPEND="${RDEPEND}"
23
24 src_unpack() {
25         git-2_src_unpack
26 }
27
28 src_install() {
29         insinto "${GAMES_DATADIR}"/${PN%_game}/games/${PN}
30         doins -r mods || die
31         doins game.conf || die
32
33         prepgamesdirs
34 }