]> Pileus Git - ~andy/sunrise/blob - games-action/meritous/meritous-1.2.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / games-action / meritous / meritous-1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit games toolchain-funcs versionator
8
9 MY_P="${PN}_v$(delete_all_version_separators $PV)_src"
10
11 DESCRIPTION="Action-adventure dungen crawl game"
12 HOMEPAGE="http://www.asceai.net/meritous/"
13 SRC_URI="http://www.asceai.net/files/${MY_P}.tar.bz2
14         ( http://omploader.org/vMTNkZg -> data-dir.patch )"
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 DEPEND="media-libs/libsdl
22         media-libs/sdl-image
23         media-libs/sdl-mixer"
24 RDEPEND="${DEPEND}"
25
26 S=${WORKDIR}/${MY_P}
27
28 src_prepare() {
29         epatch "${DISTDIR}"/data-dir.patch
30         epatch "${FILESDIR}"/Makefile-flags.patch
31         sed -ie 's/gcc/$(CC)/' Makefile || die "sed Makefile failed"
32 }
33
34 src_compile() {
35         CFLAGS="${CFLAGS} -DDATA_DIR=\\\"${GAMES_DATADIR}/meritous\\\"" \
36         emake CC=$(tc-getCC) default || die
37 }
38
39 src_install() {
40         insinto "${GAMES_DATADIR}/meritous"
41         doins -r dat/* || die
42         dogamesbin meritous || die
43         dodoc readme.txt || die
44         prepgamesdirs
45 }