]> Pileus Git - ~andy/sunrise/blob - games-action/ballistics-demo/ballistics-demo-1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / games-action / ballistics-demo / ballistics-demo-1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Super-fast 3D racing on hover bikes"
8 HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=ballistics"
9 # Patches: http://updatefiles.linuxgamepublishing.com/ballistics-demo/
10 # Unversioned filename, grrr (is pre-patched).
11 SRC_URI="http://demofiles.linuxgamepublishing.com/ballistics/${PN}.run"
12
13 LICENSE="as-is"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 RESTRICT="mirror strip"
18
19 # Not bothering with "dynamic" USE flag.
20 # Uses OSS for audio.
21 # dynamic? ( dev-games/libgrapple )
22 RDEPEND="
23         x86? (
24                 media-libs/libsdl
25                 x11-libs/gtk+
26                 x11-libs/libX11
27                 x11-libs/libXau
28                 x11-libs/libXdmcp
29                 x11-libs/libXext
30                 x11-libs/libXi )
31         amd64? (
32                 app-emulation/emul-linux-x86-gtklibs
33                 app-emulation/emul-linux-x86-sdl )"
34
35 S=${WORKDIR}
36
37 src_unpack() {
38         unpack_makeself ${PN}.run
39         unpack ./data/data.tar.gz
40
41         rm -rf data lgp_* setup*
42
43         mv bin "${T}" || die "mv"
44 }
45
46 src_install() {
47         local dir=${GAMES_PREFIX_OPT}/${PN}
48
49         exeinto "${dir}"
50         doexe "${T}"/bin/Linux/x86/* || die "doexe"
51
52         insinto "${dir}"
53         doins -r * || die "doins -r"
54
55         games_make_wrapper ${PN}-config ./ballistics_demo-config "${dir}" "${dir}"
56         games_make_wrapper ${PN} ./ballistics_demo "${dir}" "${dir}"
57         newicon icon.xpm ${PN}.xpm || die "newicon"
58         make_desktop_entry ${PN} "Ballistics (Demo)" ${PN}.xpm
59
60         prepgamesdirs
61 }