]> Pileus Git - ~andy/fetchmail/blob - dist-tools/shipper/shipper.spec
Add new gai.c debug source.
[~andy/fetchmail] / dist-tools / shipper / shipper.spec
1 Name: shipper
2 Version: 0.5
3 Release: 1
4 URL: http://www.catb.org/~esr/shipper/
5 Source0: %{name}-%{version}.tar.gz
6 License: GPL
7 Group: Utilities
8 Summary: automated shipping of open-source project releases
9 Requires: lftp, openssh-clients, freshmeat-submit
10 BuildRoot: %{_tmppath}/%{name}-root
11 BuildArch: noarch
12 #Keywords: packaging, distribution
13
14 %description 
15 shipper is a power distribution tool for developers with multiple
16 projects who do frequent releases.  It automates the tedious process
17 of shipping a software release to several standard places, including
18 ibiblio, the Red Hat submission directory, and your own hosted
19 website.  It also knows how to post a release announcement to
20 freshmeat.net via freshmeat-submit.  Two auxiliary tools, buildrpms
21 and rpm2lsm, build RPMs and generate LSM files from them respectively.
22
23 %prep 
24 %setup -q
25
26 %build
27 make %{?_smp_mflags} shipper.1 rpm2lsm.1
28
29 %install
30 [ "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
31 mkdir -p "$RPM_BUILD_ROOT"%{_bindir}
32 mkdir -p "$RPM_BUILD_ROOT"%{_mandir}/man1/
33 cp shipper rpm2lsm buildrpms "$RPM_BUILD_ROOT"%{_bindir}
34 cp shipper.1 rpm2lsm.1 "$RPM_BUILD_ROOT"%{_mandir}/man1/
35
36 %clean
37 [ "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
38
39 %files
40 %defattr(-,root,root,-)
41 %doc README COPYING
42 %{_bindir}/shipper
43 %{_bindir}/rpm2lsm
44 %{_bindir}/buildrpms
45 %{_mandir}/man1/shipper.1*
46 %{_mandir}/man1/rpm2lsm.1*
47
48 %changelog
49 * Fri Feb 6 2004 Eric S. Raymond <esr@snark.thyrsus.com> 0.5-1
50 - Added security check so the ~/.shipper and .shipper files can't be used
51   for privilege elevation.  Fixed upload omission bug in case where neither 
52   -n nor -f was on and the webpage wasn't being built.  Deliverables 
53   created for upload are deleted at end of run.
54
55 * Sun Jan 11 2004 Eric S. Raymond <esr@snark.thyrsus.com> 0.4-1
56 - Correct extraction of freshmeat name.  Build generated deliverables
57   only if we know they will be needed. Help is now available at the 
58   freshmeat-focus prompt.
59
60 * Sat Jan 10 2004 Eric S. Raymond <esr@snark.thyrsus.com> 0.3-1
61 - First alpha release of unified shipper package.  It can ship itself.
62
63 * Wed Dec 17 2003 Eric S. Raymond <esr@snark.thyrsus.com>
64 - rpm2lsm now grabs an RPM from the current directory if no argument,
65   and parses an AUTHORS file if present (GNU convention).  Also,
66   this release fixes a bug in USERNAME handling.
67
68 * Thu Aug  1 2002 Eric S. Raymond <esr@snark.thyrsus.com>
69 - Initial release of rpm2lsm, since folded into shipper package.