]> Pileus Git - ~andy/sunrise/blob - dev-vcs/tortoisehg/tortoisehg-1.1.8.ebuild
games-misc/fortune-mod-giovine01: New ebuild for bug 364357 thanks to Tommy[D]
[~andy/sunrise] / dev-vcs / tortoisehg / tortoisehg-1.1.8.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 SUPPORT_PYTHON_ABIS="1"
8 PYTHON_DEPEND="2:2.6"
9 RESTRICT_PYTHON_ABIS="2.[45] 3.*"
10
11 inherit distutils
12
13 DESCRIPTION="Mercurial GUI command line tool hgtk"
14 HOMEPAGE="http://tortoisehg.bitbucket.org"
15 SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc nautilus"
21
22 DEPEND="doc? ( >=dev-python/sphinx-1.0.3 )"
23 RDEPEND="dev-python/pygtk
24         >=dev-vcs/mercurial-1.6.3
25         >=dev-python/iniparse-0.4
26         nautilus? ( dev-python/nautilus-python )"
27
28 src_compile() {
29         distutils_src_compile
30
31         if use doc ; then
32                 emake -C doc html || die
33         fi
34 }
35
36 src_install() {
37         # make the install respect multilib.
38         sed -i -e "s:lib/nautilus/extensions-2.0/python:$(get_libdir)/nautilus/extensions-2.0/python:" setup.py || die
39
40         distutils_src_install
41         dodoc doc/ReadMe*.txt doc/TODO || die
42
43         if use doc ; then
44                 dohtml -r doc/build/html || die
45         fi
46
47         if ! use nautilus; then
48                 einfo "Excluding Nautilus extension."
49                 rm -fR "${D}"/usr/$(get_libdir)/nautilus || die
50         fi
51 }