]> Pileus Git - ~andy/sunrise/blob - dev-vcs/smartsvn/smartsvn-6.5.4.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-vcs / smartsvn / smartsvn-6.5.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils java-pkg-2
6
7 MY_PV=${PV//./_}
8 MY_P=smartsvn-generic-${MY_PV}
9
10 DESCRIPTION="GUI to SVN with extensive merge support and commit wizard"
11 HOMEPAGE="http://www.syntevo.com/smartsvn/"
12 SRC_URI="${MY_P}.tar.gz"
13 SLOT="0"
14 LICENSE="smartsvn"
15 KEYWORDS="~amd64 ~x86"
16
17 IUSE=""
18 RESTRICT="fetch"
19
20 RDEPEND=">=virtual/jre-1.4.1"
21
22 S="${WORKDIR}/${PN}-${MY_PV}"
23
24 src_install() {
25         local rdir="/opt/${PN}"
26         insinto ${rdir}
27         doins -r * || die "cannot install needed files"
28
29         java-pkg_regjar ${rdir}/lib/${PN}.jar
30
31         java-pkg_dolauncher ${PN} "--java-args -Xmx256 --jar ${PN}.jar"
32
33         for X in 32 48 64 128
34         do
35                 insinto /usr/share/icons/hicolor/${X}x${X}/apps
36                 newins "${S}/bin/${PN}-${X}.png" "${PN}.png" || die "cannot install needed files"
37                 insinto /usr/share/icons/hicolor/scalable/apps
38                 newins "${S}/bin/${PN}.svg" "${PN}.svg" || die "cannot install needed files"
39         done
40
41         make_desktop_entry "${PN}" "SmartSVN" ${PN} "Development;RevisionControl" || die "cannot create desktop entry"
42 }
43
44 pkg_nofetch(){
45         einfo "Please download ${MY_P}.tar.gz from:"
46         einfo "${HOMEPAGE}download.html?file=smartsvn/${MY_P}.tar.gz"
47         einfo "and move/copy to ${DISTDIR}"
48 }