]> Pileus Git - ~andy/sunrise/blob - dev-vcs/smartcvs/smartcvs-7.0.9.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-vcs / smartcvs / smartcvs-7.0.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils java-pkg-2
6
7 MY_PV=${PV//./_}
8 MY_P=smartcvs-generic-${MY_PV}
9
10 DESCRIPTION="A powerful CVS GUI with compare/merge support"
11 HOMEPAGE="http://www.syntevo.com/smartcvs/"
12 SRC_URI="${MY_P}.tar.gz"
13 SLOT="0"
14 LICENSE="smartcvs"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RESTRICT="fetch"
19
20 RDEPEND=">=virtual/jre-1.4.1"
21
22 S="${WORKDIR}/${PN}-${MY_PV}"
23
24 src_install() {
25         local rdir="/opt/${PN}"
26         insinto ${rdir}
27         doins -r * || die
28         java-pkg_regjar ${rdir}/lib/${PN}.jar
29         java-pkg_dolauncher ${PN} "--java-args -Xmx256 --jar ${PN}.jar"
30         for X in 32 48 64 128
31         do
32                 insinto /usr/share/icons/hicolor/${X}x${X}/apps
33                 newins "${S}/bin/${PN}-${X}x${X}.png" "${PN}.png" || die "cannot install needed files"
34         done
35         make_desktop_entry ${PN} "SmartCVS" ${PN}.png "Development;RevisionControl"
36 }
37
38 pkg_nofetch() {
39         einfo "Please download ${MY_P}.tar.gz from:"
40         einfo "http://www.syntevo.com/smartcvs/download.html?file=smartcvs%2Fsmartcvs-generic-${MY_PV}.tar.gz"
41         einfo "and move/copy to ${DISTDIR}"
42 }