]> Pileus Git - ~andy/sunrise/blob - dev-util/uno/uno-2.13.ebuild
x11-wm/qlwm: Fix qt deps
[~andy/sunrise] / dev-util / uno / uno-2.13.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="A tool for analyzing the source code of programs written in ANSI-C"
8 HOMEPAGE="http://spinroot.com/uno/"
9 SRC_URI="http://spinroot.com/${PN}/${PN}_v${PV/./}.tar.gz"
10
11 LICENSE="as-is"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
15
16 S="${WORKDIR}/${PN}/src"
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21
22         epatch "${FILESDIR}/${PV}-makefile.patch"
23 }
24
25 src_compile() {
26         emake CC="$(tc-getCC)" || die "emake failed"
27 }
28
29 src_install() {
30         dobin uno uno_local uno_global
31         doman ../doc/uno.1
32
33         insinto /usr/share/${PN}
34         doins -r ../prop
35
36         if use doc ; then
37                 dodoc ../doc/*.pdf
38         fi
39 }