]> Pileus Git - ~andy/sunrise/blob - dev-util/tla/tla-1.3.5.ebuild
Bug 59548 - copy dev-util/tla ebuild from portage tree; already masked and soon will...
[~andy/sunrise] / dev-util / tla / tla-1.3.5.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 S="${WORKDIR}/${P}/src/=build"
6 DESCRIPTION="Revision control system ideal for widely distributed development"
7 HOMEPAGE="http://savannah.gnu.org/projects/gnu-arch http://wiki.gnuarch.org/ http://arch.quackerhead.com/~lord/"
8 SRC_URI="http://ftp.gnu.org/gnu/gnu-arch/${P}.tar.gz
9         http://dev.gentooexperimental.org/~dreeevil/tla.1-2.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sh ~sparc ~x86"
14 IUSE="doc"
15
16 DEPEND="sys-apps/coreutils
17         sys-apps/diffutils
18         sys-devel/patch
19         sys-apps/findutils
20         sys-apps/gawk
21         app-arch/tar
22         sys-apps/util-linux
23         sys-apps/debianutils
24         sys-devel/make"
25
26 src_unpack() {
27         unpack ${P}.tar.gz
28         unpack tla.1-2.gz
29         mkdir "${S}"
30         cd "${WORKDIR}/${P}"
31         sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
32 }
33
34 src_compile() {
35         OPTIONS="--prefix=/usr --with-posix-shell=/bin/bash "
36
37         if [[ -n $CC ]]
38         then
39                 ../configure ${OPTIONS} --with cc="$CC $CFLAGS" || die "configure failed"
40         else
41                 ../configure ${OPTIONS} || die "configure failed"
42         fi
43         # parallel make may cause problems with this package
44         make || die "make failed"
45 }
46
47 src_install () {
48         make install prefix="${D}/usr" || die "make install failed"
49
50         cd "${S}"/..
51         dodoc ChangeLog
52
53         if use doc; then
54                 cd docs-tla
55                 docinto html
56                 dohtml -r .
57
58                 cd ../docs-hackerlab
59                 docinto hackerlab/html
60                 dohtml html/*
61                 docinto hackerlab/ps
62                 dodoc ps/*
63         fi
64
65         cd "${WORKDIR}"
66         mv tla.1-2 tla.1
67         doman tla.1
68
69         chmod 755 "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
70         cp -pPR "${WORKDIR}/${P}/src/tla/=gpg-check.awk" "${D}/usr/bin/tla-gpg-check.awk"
71 }