]> Pileus Git - ~andy/sunrise/blob - dev-util/tla/tla-1.3.5.ebuild
net-misc/fatrat: Properly fix qt deps
[~andy/sunrise] / dev-util / tla / tla-1.3.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 S="${WORKDIR}/${P}/src/=build"
6 DESCRIPTION="Revision control system ideal for widely distributed development"
7 HOMEPAGE="http://savannah.gnu.org/projects/gnu-arch http://wiki.gnuarch.org/ http://arch.quackerhead.com/~lord/"
8 SRC_URI="mirror://gnu/gnu-arch/${P}.tar.gz
9         http://gentooexperimental.org/~patrick/tla.1-2.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sh ~sparc ~x86"
14 IUSE="doc"
15
16 DEPEND="sys-apps/debianutils"
17 RDEPEND=${DEPEND}
18
19 src_unpack() {
20         unpack ${A}
21         mkdir "${S}"
22         sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${P}/src/tla/=gpg-check.awk" || die
23 }
24
25 src_compile() {
26         ../configure --prefix=/usr --with-posix-shell=/bin/bash || die "configure failed"
27         # parallel make may cause problems with this package
28         emake -j1 || die "emake failed"
29 }
30
31 src_install () {
32         make install prefix="${D}/usr" || die "make install failed"
33
34         cd ..
35         dodoc ChangeLog || die
36
37         if use doc; then
38                 cd docs-tla
39                 docinto html
40                 dohtml -r . || die
41
42                 cd ../docs-hackerlab
43                 docinto hackerlab/html
44                 dohtml html/* || die
45                 docinto hackerlab/ps
46                 dodoc ps/* || die
47         fi
48
49         cd "${WORKDIR}"
50         mv tla.1-2 tla.1 || die
51         doman tla.1 || die
52
53         newbin "${WORKDIR}/${P}/src/tla/=gpg-check.awk" tla-gpg-check.awk || die
54 }