]> Pileus Git - ~andy/sunrise/blob - dev-util/tinyxml/tinyxml-9999.ebuild
6b404120c251baaa9abab57d7b297508f1694dc0
[~andy/sunrise] / dev-util / tinyxml / tinyxml-9999.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 ECVS_SERVER="tinyxml.cvs.sourceforge.net:/cvsroot/tinyxml"
6 ECVS_MODULE="tinyxml"
7 inherit eutils cvs
8
9 MY_PV=cvs
10 DESCRIPTION="A simple C++ XML parser that can be easily integrating into other programs"
11 HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
12 SRC_URI=""
13
14 LICENSE="GPL-2"
15 KEYWORDS="~x86"
16 SLOT="0"
17 IUSE="debug doc examples"
18
19 DEPEND="dev-util/scons
20         doc? ( app-doc/doxygen )"
21 RDEPEND=""
22
23 S="${WORKDIR}/${PN}"
24
25 src_compile() {
26         use debug && myconf="debug=0"
27         scons ${MAKEOPTS} ${myconf} sharedlibrary=1 program=0 || die "scons failed"
28         if use doc ; then
29                 doxygen dox || die "doxygen failed"
30         fi
31 }
32
33 src_install () {
34         insinto /usr/include
35         doins *.h || die "installing headers failed"
36         dolib libtinyxml.so || die "installing library failed"
37         dodoc {changes,readme}.txt
38         if use doc ; then
39                 dohtml docs/* || die "installing docs"
40         fi
41         if use examples ; then
42                 insinto /usr/share/doc/${PF}/samples
43                 doins *.xml xmltest.cpp || die "installing examples"
44         fi
45 }