]> Pileus Git - ~andy/sunrise/blob - dev-util/ticpp/ticpp-0_p20100924.ebuild
dev-util/gengetopt: version bump for gengetopt
[~andy/sunrise] / dev-util / ticpp / ticpp-0_p20100924.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="A completely new interface to TinyXML that uses MANY of the C++ strengths"
6 HOMEPAGE="http://code.google.com/p/ticpp/"
7 SRC_URI="http://sulmonalug.it/files/mrfree/${P}.tar.bz2"
8
9 LICENSE="GPL-2"
10 KEYWORDS="~amd64"
11 SLOT="0"
12 IUSE="debug doc"
13
14 DEPEND="dev-util/premake
15         doc? ( app-doc/doxygen sys-apps/sed )"
16 RDEPEND=""
17
18 src_compile() {
19         local myconf
20
21         premake --target gnu || die "creating Makefile failed"
22
23         if use !debug ; then
24                 myconf="CONFIG=Release"
25         fi
26
27         emake ${myconf} || die "emake failed"
28
29         if use doc ; then
30                 sed -i -e '/GENERATE_HTMLHELP/s:YES:NO:' dox || die "sed failed"
31                 doxygen dox || die "doxygen failed"
32         fi
33 }
34
35 src_install () {
36         insinto /usr/include/ticpp
37         doins *.h || die "installing headers failed"
38
39         if use debug ; then
40                 dolib ../lib/libticppd.a || die "installing library failed"
41         else
42                 dolib ../lib/libticpp.a || die "installing library failed"
43         fi
44
45         dodoc {changes,readme,tutorial_gettingStarted,tutorial_ticpp}.txt || \
46                 die "dodoc failed"
47
48         if use doc ; then
49                 dohtml -r docs/* || die "installing docs failed"
50         fi
51 }