]> Pileus Git - ~andy/sunrise/blob - dev-util/stressapptest/stressapptest-1.0.0.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-util / stressapptest / stressapptest-1.0.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils flag-o-matic
8
9 MY_P="${P}_autoconf"
10
11 DESCRIPTION="Stressful Application Test"
12 HOMEPAGE="http://code.google.com/p/stressapptest/"
13 SRC_URI="http://stressapptest.googlecode.com/files/${MY_P}.tar.gz"
14
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 LICENSE="Apache-2.0"
18 IUSE="debug"
19
20 S="${WORKDIR}"/${MY_P}
21
22 src_prepare() {
23         epatch \
24                 "${FILESDIR}"/${PV}-flags.patch \
25                 "${FILESDIR}"/${PV}-nolicense.patch
26         eautoreconf
27         use debug || append-flags -DNDEBUG
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install || die
32 }