]> Pileus Git - ~andy/sunrise/blob - dev-util/scmbug/scmbug-0.23.4.ebuild
app-misc/japanese-vocabulary: Adding ~amd64 keyword, fixing qt deps properly
[~andy/sunrise] / dev-util / scmbug / scmbug-0.23.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils versionator
6
7 MY_P=SCMBUG_RELEASE_$(replace_all_version_separators -)
8
9 DESCRIPTION="integrates verion control system with bug trackers"
10 HOMEPAGE="http://www.mkgnu.net/?q=scmbug"
11 SRC_URI="http://files.mkgnu.net/files/scmbug/${MY_P}/source/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 DEPEND="doc? ( media-gfx/transfig )"
19 RDEPEND="dev-perl/Mail-Sendmail"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         # Remove threads dependency which crashes SCMBUG at startup
28         # and use fork instead
29         epatch "${FILESDIR}/${P}-threads.patch"
30 }
31
32 src_compile() {
33         econf $(use_with doc)
34         emake || die "emake failed"
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install || die "emake install failed"
39 }