]> Pileus Git - ~andy/sunrise/blob - dev-util/reviewboard/reviewboard-1.5.5.ebuild
dev-util/eresi: Remove unneeded base eclass
[~andy/sunrise] / dev-util / reviewboard / reviewboard-1.5.5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils python versionator
12
13 MY_PN=ReviewBoard
14 MY_PV=$(replace_version_separator '_' '') # only needed for beta release
15 MY_P=${MY_PN}-${MY_PV}
16
17 DESCRIPTION="A web-based tool for tracking of pending code changes to help code reviews"
18 HOMEPAGE="http://www.reviewboard.org/"
19 SRC_URI="http://downloads.${PN}.org/releases/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE=""
25
26 RDEPEND="dev-python/django-evolution
27         dev-python/Djblets
28         dev-python/flup
29         dev-python/imaging
30         dev-python/paramiko
31         dev-python/pygments
32         dev-python/pytz
33         dev-python/recaptcha-client
34         || ( dev-python/django[sqlite] dev-python/django[mysql] dev-python/django[postgres] )
35         || ( ( www-apache/mod_python www-servers/apache ) virtual/httpd-fastcgi )"
36
37 S=${WORKDIR}/${MY_P}
38
39 pkg_postinst() {
40         distutils_pkg_postinst
41         elog "You must install any VCS tool you wish ${PN} to support."
42         elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or dev-util/subversion."
43         elog
44         elog "Enable the mysql, postgres or sqlite USEflag on dev-python/django"
45         elog "to use the corresponding database backend."
46         elog
47         elog "For speed and responsiveness, consider installing net-misc/memcached"
48         elog "and dev-python/python-memcached"
49 }