]> Pileus Git - ~andy/sunrise/blob - dev-util/reviewboard/reviewboard-1.0.8.ebuild
dev-util/reviewboard: Added missing dep dev-python/django-evolution, thanks to Sean...
[~andy/sunrise] / dev-util / reviewboard / reviewboard-1.0.8.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 MY_PN=ReviewBoard
8 MY_P=${MY_PN}-${PV}
9
10 inherit distutils python versionator
11
12 DESCRIPTION="A web-based tool designed to track of pending code changes and make code reviews much less painful"
13 HOMEPAGE="http://www.reviewboard.org/"
14 SRC_URI="http://downloads.${PN}.org/releases/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 RDEPEND="dev-python/django
22         dev-python/django-evolution
23         dev-python/djblets
24         dev-python/flup
25         dev-python/imaging
26         dev-python/imaging
27         dev-python/paramiko
28         dev-python/pygments
29         dev-python/python-memcached
30         dev-python/pytz
31         || ( ( www-servers/apache
32                 || ( www-apache/mod_fastcgi www-apache/mod_python ) )
33                 www-servers/lighttpd )"
34
35 S=${WORKDIR}/${MY_P}
36
37 pkg_postinst() {
38         distutils_pkg_postinst
39         elog "For support of a certain VCS, please install"
40         elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or dev-util/subversion."
41         elog "Please emerge django with mysql, postgres or sqlite USE flag"
42         elog "for the corresponding database backends."
43 }